Aico 3000 Range
This official sponsor may provide discounts for members
Advertisement - Content continues below
Advertisement - Content continues below

Discuss Power to tail light problem in the Auto Electrician Forum area at ElectriciansForums.net

Welcome to ElectriciansForums.net - The American Electrical Advice Forum
Head straight to the main forums to chat by click here:  American Electrical Advice Forum

One of my tail lights remains on permanently. When l switch it on it turns off. The other tail light works as it should. Can someone please help?
 
uHeat Banner - Forum Discount Available
This official sponsor may provide discounts for members
Advertisement - Content continues below

telectrix

-
Mentor
Arms
Esteemed
possible bad earth, maybe on another light in either rear cluster. check for corrosion
 

Simon47

-
Arms
Bad earth to light cluster and "something" is pulling the cluster "earth" up towards 12V ? When you switch lights on, the lamp goes out because it's now between 12V and 12V.
Probably not full on and off - more likely dim and dimmer.
You see it a fair bit where a tail light is on but goes off when either brake or indicator is used - with brake/indicator light not coming on.
So first check, measure voltage between earth on the light and chassis.
 
Aico 3000 Range
This official sponsor may provide discounts for members
Advertisement - Content continues below

Reply to Power to tail light problem in the Auto Electrician Forum area at ElectriciansForums.net

Advertisement - Content continues below
Top Bottom