Electrical2Go - Online Electrical Supplier
This official sponsor may provide discounts for members

Discuss RCD problems in the Periodic Inspection Reporting & Certification area at ElectriciansForums.net

M

Modernelectric

Welcome to ElectriciansForums.net - The American Electrical Advice Forum
Head straight to the main forums to chat by click here:  American Electrical Advice Forum

I have fitted a dual rcd board, and everything has tested fine. my only problem is that the rcd's do not trip on the 180 phase roatation, but trip within limits on the 0 phase rotation. I have swapped both rcds for new to check that the rcd's werent faulty and i still have the same problem.

Has anyone had any problems like this? any clues because this one is ****ing me off.

thanks!
 
Last edited by a moderator:
SuperlecDirect - ElectriciansForums.net Electrical Suppliers
This official sponsor may provide discounts for members
Aico 3000
S

Spudnik

  • Thread Starter Thread Starter
  • #2
May sound daft bit would your tester be fautly?

Have you since used it on any other installs?
 
M

Modernelectric

  • Thread Starter Thread Starter
  • #3
Yes ive used it on other installs and its fine, its only a few months old, it seems no one else has encountered this problem then?! its a mystery to me.
 
O

Ohmagain

  • Thread Starter Thread Starter
  • #4
was any reason for this every found?
 
B

Badged01

  • Thread Starter Thread Starter
  • #5
With no further update from the original poster Im gonna guess operator error!
 
uHeat Banner - Forum Discount Available
This official sponsor may provide discounts for members

Reply to RCD problems in the Periodic Inspection Reporting & Certification area at ElectriciansForums.net

Top Bottom