• Thanks for visiting ElectriciansForums.net. We hope you find the information you are looking for. But if you don't manage to, please feel free to Register and ask a question yourself. You can delete your account at any time should you quickly find the answers to what you need.

Discuss Ads have gone nuts again - my bad in the ElectriciansForums.net News and Updates area at ElectriciansForums.net

Dan

Admin
Staff member
Welcome to ElectriciansForums.net - The American Electrical Advice Forum
Head straight to the main forums to chat by click here:  American Electrical Advice Forum

I'm trying to show ads on a usergroup basis. So unregistered see most, registered less, arms even less, staff nearly none, subscribed none at all.

Google has setup auto-ads for plebs who don't know what they're doing (or because they just want MAX ads everywhere - even though they've literally just launched a 'less intrusive ads' rule themselves) and it means that even if I have a single ad showing to a member on a page, auto ads stick them everywhere else on that page.

The way I used to do it, manually add the advert in code where I want it, and code to who it will be shown and when, doesn't seem to work well at all. So I'm trying different ways to stop it. I thought I clocked another way, but on mobile it has gone nuts again.

And the worse thing is, it depends on what device you're on, how often you come here, and where you're based (as to which advertisers are buying the slots) so I can't always tell what you're seeing - and you each see different in a lot of cases too.

I think this was the problem a month or so ago when I was convinced I'd got it, and then it took you guys to tell me a dozen times for me to check various stats and see what ads were being shown and billed (I still to this day never saw the actual ads - but got your screen prints).

So. I'm messing around with these a bit later. Got to get my new glasses first. It's killing my eyes (my astigmatism has got worse) and I'm leaning forward to see the laptop (gonna end up like one of those little old men who walk around in a question mark shape! lol) so it's killing my back where I fractured it a couple of years ago too.

So lemme go get my glasses, nip my mums for tea, and I'll be back to try another way in a bit.

Was up till 2:30am trying to sort this out last night. @Lou said don't change anything it's alright. I said let me just try one more time, I can't be beaten by this just because Google wants to milk 'publishers' (what we're classed as to them). We're not the bloody mirror online. Their site sucks for ads. And they own all the little local publishers now too so their sites are the same. Can't stand the bloody things.

Anyway, rant over, that's the score. No point screen printing me anything YET. But I will ask you to later.
 
Cheers ,(saved some comparisons !)
my situation changes drastically as I shrink/zoom.
(zoomed 120% firefox- only see Electrical 2 Go with DAB vote)
 

Dan

Admin
Staff member
  • Thread Starter Thread Starter
  • #3
Yeah I get that. Go landscape with your phone or tablet and it does that. Luckily literally nobody does it unless testing lol

Sponsors bar will be there always, unless you subscribe (this isn't a ploy to get subscribers by the way - this is a problem that needs fixing regardless).

This forum perhaps isn't doing it as much as tilers and plumbers.

Lou can't get as many (Google) ads to show as me. They're all over the place on plumbers. Google is trying to squeeze one in where avatars go!!!!! - WTF it that about. Not even people who can't code and use this silly auto-ads thing can't accept that position, surely?!
 

Dan

Admin
Staff member
  • Thread Starter Thread Starter
  • #4
Now they are saving a slot but not showing an actual ad! That's even bloody worse!

Just letting you know I'm still on this. I'll update this thread when I (think) I've finished and get you screen print any showing still so I can tweak them out.

It takes 20 minutes or so to update any changes I make in the google system. And then we've got caches being used via cloudflare and whatnot too. So it's just taking a bit of time.
 

littlespark

-
Arms Access
Well done @Dan for all your work.
Can't visit any website without being bombarded by ads.... This forum is one of the better ones to be honest.
 

telectrix

-
Arms Access
whatever youare doing, Dan, seems to be working. i've not had an ad. for a russian tart for over an hour.
 

Dan

Admin
Staff member
  • Thread Starter Thread Starter
  • #7
If you post to the forum a fair bit, you should (or at least will eventually) not see many ads at all. Sponsors sidebar will always show unless you subscribe (you will always still see their content in the forums and their accounts and us posting about them and lists of sponsors everywhere in actual forums etc).

But this is taking the mick, there is an ad-slot Google has picked and changed the shape of the page for, in a massive way right at the top of the forum - and then decided not to show an ad.

1567966511184.png

WTF is that all about?!?!!

Others are clicking the back button (moreso on plumbers but they're setup the same so I wouldn't be surprised if later it kicks in here or something) and getting that really annoying pop-up one. That's an extra click then to get to the page you want. And stats show that 2 clicks into a website you've already decided whether you're staying for ages or never visiting it again. So Google is costing me AND google themselves traffic there.

This is because bloggers don't know code. And they're making their tools "simple to use" for them.
 

Dan

Admin
Staff member
  • Thread Starter Thread Starter
  • #8
I'm working on this still, just letting you know. Problem is, when I hide them all from logged in users, it's doing it for those logged out still, and I'm not noticing it, or having it reported to me. So I'm needing to show them TO ME while I'm fixing them. And am getting side tracked while I'm doing it.

It actually makes us earn less money, in a roundabout way. So there's no way I'm doing this for more money. And I'm definitely not doing it for the nice looks and smart layout pmsl

I am on this. And it'll be super short term. It's one of those things I'm needing to do this last one time. Wont need mess again until we need to upgrade the forum again.
 

Dan

Admin
Staff member
  • Thread Starter Thread Starter
  • #9
These should have calmed down.

There's one hiding somewhere, but not loading an actual ad. Just sticking a big 'whitespace' there. I can't find it. It's doing my head in. I keep coming back to it to try find it. Might be one of those things that just goes on its own randomly.
 

Are there enough independent certification companies?

  • Yes

  • No


Results are only viewable after voting.

Trending Threads

Top Bottom