Discuss Solariboost+ failed again in the Solar PV Forum | Solar Panels Forum area at ElectriciansForums.net

Tonyt1

DIY
Reaction score
0
Welcome to ElectriciansForums.net - The American Electrical Advice Forum
Head straight to the main forums to chat by click here:   American Electrical Advice Forum

My first solariboost+ was installed in 2015. In July 2019 it went dead, power good. Marlec supplied me with a reduced cost unit (£149) which was installed the same month, now this one has failed in less than three years. The immersion heater element was new about three years ago and still works perfectly. Marlec are offering me another one for £149. Having done some research, it seems failure is common, often soon after the warranty expires. I'm reluctant to buy another, and am looking at a solic200. Any thoughts?
 

robato

DIY
Reaction score
0
I was tempted to get an iBoost but was swayed with the simplicity of the Solic 200 which is supposedly made to last 25 years as well as being one of the lowest cost options out there, meaning it pays for itself within 2-3 years. I also liked that the wired version is fitted next to the consumer unit rather than installing it inside a hot airing cupboard, and has no moving parts (no noisy fan!).

However, I'm not sure either device is that good when used with a home battery which I'm considering on getting along with an EV.
 

RobWi11s

DIY
Reaction score
0
My first solariboost+ was installed in 2015. In July 2019 it went dead, power good. Marlec supplied me with a reduced cost unit (£149) which was installed the same month, now this one has failed in less than three years. The immersion heater element was new about three years ago and still works perfectly. Marlec are offering me another one for £149. Having done some research, it seems failure is common, often soon after the warranty expires. I'm reluctant to buy another, and am looking at a solic200. Any thoughts?
I too had problems with an iBoost on two occasions. Both times I was lucky to be within warranty. On one occasion it was fixed with replacement of an internal fuse according to the supplier. I was actually looking at getting an Apollo GEM to replace it but unfortunately they have just stopped manufacturing them.
 

Reply to Solariboost+ failed again in the Solar PV Forum | Solar Panels Forum area at ElectriciansForums.net

Similar Threads

Hi I am a sparks from the 15th Ed, did 16, 17 and last year 18th. I am out of practice though as have been office based for 12+ years in a...
Replies
8
Views
620
TLDR: is there a legal requirement to have a landlords supply to power an L2 alarm system? Mornin'. Non-electrician, under the cosh from an iffy...
Replies
6
Views
866
My system has had an intermittent problem for the last few months. The inverter has occasionally been reporting PV Voltage Too High, then it would...
Replies
5
Views
3K
Hi All, more by way of a query really, we had an Iboost (immersion heater proportional controller for diverting excess solar power) installed...
Replies
5
Views
4K

New Posts (Please Reply)

Top