Electrical2Go - Online Electrical Supplier
This official sponsor may provide discounts for members
Advertisement - Content continues below
Advertisement - Content continues below

Discuss megger 1552 problem in the Periodic Inspection Reporting & Certification area at ElectriciansForums.net

4

4x4 mark

Welcome to ElectriciansForums.net - The American Electrical Advice Forum
Head straight to the main forums to chat by click here:  American Electrical Advice Forum

ive had my megger for just short of a year and today after changing a consumer unit i got a strange reading when testing the rcd trip times.
it will not auto test, ie run through the test sequence by itself, it just displays >50v. if you take each test on its own it will 1/2 test 1x test and ramp test but it will not 5x test just shows same message.
i know you can change test voltages between 25v and 50v but i assume that the megger is at fault as it seems to do this at the output side of the rcd as well as a socket. is this the megger not putting the test voltage out to the circuit, yes the circuit is energised, i also tried changing the batteries but still the same.

cheers mark
 
SuperlecDirect - ElectriciansForums.net Electrical Suppliers
This official sponsor may provide discounts for members
Advertisement - Content continues below
S

Spudnik

  • Thread Starter Thread Starter
  • #2
I wouldnt mess about, Mark.

Get it to the repair shop pronto.

It should still be covered by warranty, assuming you bought new.
 
The Megger shows >50 and stops the test when it suspects that continuing with the test will raise the potential of the earth above 50V. This sometimes happens when the Ze is very high, for instance on a TT system with a unsatisfactory electrode.
Does this tally with what you are testing?
 
4

4x4 mark

  • Thread Starter Thread Starter
  • #4
tried it on a check box at work and it wouldn't "trip" the check box, so its away at the mo for a health check and calibration. had some ****** auld rubbish off the company i work for took me twice as long to do a test as every time i tried to test a circuit it wanted to put the result in the memory instead of just displaying it.
 
Last edited by a moderator:
CK Tools :) The professionals choice when it comes to Electrical Tools
This official sponsor may provide discounts for members
Advertisement - Content continues below

Reply to megger 1552 problem in the Periodic Inspection Reporting & Certification area at ElectriciansForums.net

Aico 3000 Range
This official sponsor may provide discounts for members
Advertisement - Content continues below
Top Bottom