Electrical2Go - Online Electrical Supplier
This official sponsor may provide discounts for members

Discuss Underfloor Heating (Devimat) in the Electrical Forum area at ElectriciansForums.net

L

louiek

Welcome to ElectriciansForums.net - The American Electrical Advice Forum
Head straight to the main forums to chat by click here:  American Electrical Advice Forum

Hi - is anyone familiar with the devimat underfloor heating system? The system is being used in a bathroom to heat tiles. The system uses a floor thermostat as well as a room thermostat. The controller is situated outside the bathroom. For some reason the floor is not heating up - this happened after the power was off for about an hour.

Have reset the system etc. and all seems ok but the floor is just not heating up. Although the thermostat is set to number 6, the controller keeps clicking off about every 2 minutes and reverting back to number 5.

Any thoughts on this? Could it be a faulty floor thermostat?

Thanks
 
SuperlecDirect - ElectriciansForums.net Electrical Suppliers
This official sponsor may provide discounts for members
D

Dave

  • Thread Starter Thread Starter
  • #2
Sounds like a thermostat prob or maybe the sensor....

Give devi a ring and they might be able to fault find for you..

DEVI Electroheat Ltd.
Brickfields Business Park, Woolpit,
Bury St. Edmunds
Suffolk IP30 9QS

Tel: 0845 434 9991
Fax: 0845 434 9489

or email technical

Technical - [email protected]
 
L

louiek

  • Thread Starter Thread Starter
  • #3
Think you're right as the controller doesn't seem right at all now - thanks for that - will speak to Devimat
 

Reply to Underfloor Heating (Devimat) in the Electrical Forum area at ElectriciansForums.net

Top Bottom